SlapOS is a decentralized Cloud Computing technology that can automate the deployment and configuration of applications in a heterogeneous environment.
1 - 2 of 2 records - 0 items selected


As i'm interested in decentralized clouds, i've been trying to install a sample master/comp-0 slapos between two hosted servers lately.

The First time, i followed the tutorials with single line installers, and after chmod/chowning the /etc/slpos-ssl dir, i could connect the two servers and install the apache frontend.

Alas, the instanciation of frontend kept doing nothing with warnings about slappart* dirs not empty so that i was blocked

then i reinstalled both my servers with debian 8.10 to restart from scratch.

apart from here, i got this error when i play the bash slapos command on COMP-0 :

onnectionError: Couldn't connect to the server. Please double check given master-url argument, and make sure that IPv6 is enabled on your machine and that the server is available. The original error was:
HTTPSConnectionPool(host='XX.XX.XX.XX', port=5443): Max retries exceeded with url: /loadComputerConfigurationFromXML (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fdb5f4b9bd0>: Failed to establish a new connection: [Errno 111] Connection refused',))

this time, i can see the computer created on the dashboard, but the slots are grey, neither green orange or red.

i tried to access the vifib forum, but the links i found were dead, so i post here.

does anyone know the source of this error, knowing the i already 100x checked master-url, ipv6 and firewalls ?


[solved] by Unknown User at 2018/07/04

ok, the solution is: no apt-get update