VIFIB DESCENTRALIZED CLOUD COMPUTING

SlapOS is a decentralized Cloud Computing technology that can automate the deployment and configuration of applications in a heterogeneous environment.
1 - 7 of 7 records
Summary

Hello,

I am creating a new ERP5 instance inside a slaprunner wchich hosted by vifib.net, and building a new ERP5 instance inside it. But I can not build the software release, at least it doesn't seem working. 

0. get slaprunner instance and goto  https://softinstxxxx.host.vifib.net/

1. git clone https://example.com/foo.git  inside the slap partition

# The foo.git  contains software.cfg to build erp5.

2. click 'Open Software Release'

3. Select a folder which contains software.cfg

4. Click 'Open software'

5. Run # Click the green triangle button.

6. Forwarded to logs 

 but it says 'Warning: log file doesn't exist yet or empty log!!' 

What was wrong? How should I do? What should I check? 

Thanks in advance, 

Tatuya 

Note: the build and run configuration is following. 

Which one do you want to run ?

Build :
Run :

How many tries ?

Max times for Build :

Max times for Run :

Max time for build: 2

Max time for rune: 3

(I think this is the default setting of slaprunner) 

Tatuya  

You can use the editor to see the log also (change from Project to Workspace), normaly this happens "No log file .." at begin, and after a minute (or less), it shows up. 

From: Unknown User

Max time for build: 2

Max time for rune: 3

(I think this is the default setting of slaprunner) 

Tatuya  


Thank you,

But even spending 50 hours, nothing has been created. No logs, no software parts, etc.

It seems "slap node software (slapgrid-sr)" has not been triggered at all. 

Tatuya 

I am not sure this is related but I find one error message on JavaScript console

when clicking "Run" button. 

 GET https://softinst56809.host.vifib.net/static/js/jquery/jquery.fancytree-all.min.js.map 404 (NOT FOUND)

Hi,

May be this can solve your problem: Stop and start again your webrunner instance.

I think webrunner is failling to start/stop some process. 

Regards,

Alain 

From: Unknown User
Hi,

May be this can solve your problem: Stop and start again your webrunner instance.

I think webrunner is failling to start/stop some process. 

Regards,

Alain 

Thank you Alain,

Now it seems working.

Tatuya 

-- 

Note: For someone who have the same problem

To check webrunner status looking at the following log is helpful. 

0. login own slappartition

1. less /srv/slapgrid/<slappartition>/var/log/slapproxy.log